Сортировка таблиц

Вся информация об основных элементах системы (пользователи, организации, слои, отчеты и т.д.) представлена на соответствующих вкладках в табличном виде. Используя эти таблицы, администратор может провести сортировку имеющихся данных.

Чтобы упорядочить информацию о конкретном элементе системы, перейдите на вкладку с этим элементом и нажмите левой кнопкой мыши по заголовку той графы, по данным которой должна пройти сортировка. При повторном нажатии на заголовок графы сортировка пройдет в обратном порядке.

Поисковая строка и фильтр

При переходе на интересующую администратора вкладку в правой части страницы становится доступной поисковая строка, которая предназначена для поиска конкретных данных в панели администрирования.

Чтобы осуществить поиск элемента, введите часть его названия в поисковую строку, после чего в окне администрирования отобразятся все элементы, соответствующие введенному запросу. Поиск может быть осуществлен по всем элементам системы.

Кроме того, администратор может воспользоваться фильтром, который расположен под поисковой строкой. Он необходим для сортировки данных по уже заданным критериям поиска.

Чтобы система выдала наиболее точные результаты поиска, администратор может воспользоваться поисковой строкой и фильтром одновременно (там, где доступны сразу два этих элемента). Фильтр не доступен в следующих разделах: управление (вкладка "Организации"), слои (вкладка "Группы"), отчеты (вкладка "Список отчетов") и справочники (вкладка "Изображения").

Добавление новой записи

В панели администрирования авторизованному пользователю доступен инструмент добавления новых элементов в систему. Чтобы добавить новый элемент, пользователю необходимо перейти в интересующий его раздел и нажать на появившуюся в окне администрирования кнопку "Создать".

При нажатии на эту кнопку открывается новое окно, в котором пользователю необходимо заполнить обязательные поля для ввода и нажать на кнопку "Сохранить и выйти". Для отмены добавления нового элемента, необходимо нажать на кнопку "Отмена".

Кнопка "Создать" доступна во всех разделах блока "Меню", кроме разделов "Отчеты" и "Управление" (вкладки "Права доступа" и "Права на группы").

Редактирование записи

В окне администрирования пользователю доступно редактирование существующих элементов. Чтобы изменить данные о некотором элементе, пользователю необходимо перейти в интересующий его раздел, навести курсор мыши на строку с названием элемента и нажать на кнопку edit_icon - "Редактировать", которая расположена в правой части выделенной строки.

При нажатии на эту кнопку в окне администрирования открывается форма, в которой пользователю необходимо ввести новую информацию о выбранном элементе и нажать на кнопку "Сохранить и выйти". Чтобы отменить редактирование элемента, необходимо нажать на кнопку "Отмена".

Кроме того, форма для редактирования может быть открыта путем двойного нажатия левой кнопкой мыши по строке с названием элемента. Пользователю доступно редактирование во всех разделах блока "Меню", кроме разделов "Управление" (вкладки "Права доступа" и "Права на группы") и "Отчеты" (вкладка "Права на отчеты").

Удаление записи

В панели администрирования пользователю доступен инструмент для удаления элементов из системы. Чтобы удалить конкретный элемент, пользователю необходимо перейти в интересующий его раздел, навести курсор мыши на строку с названием этого элемента и нажать на кнопку delete_icon - "Удалить", которая расположена в правой части выделенной строки.

При нажатии на эту кнопку в окне администрирования открывается диалоговое окно, подтверждающее удаление элемента. Чтобы удалить элемент из системы, пользователю необходимо нажать на кнопку "Ок". Чтобы отменить удаление, необходимо нажать на кнопку "Отмена".

Кроме того, в системе предусмотрен инструмент для удаления сразу нескольких элементов. Для этого пользователю необходимо навести курсор мыши на строки с этими элементами и поставить галочку напротив их названий. После этого в нижней части окна администрирования становится доступной кнопка "Удалить". При нажатии на эту кнопку открывается диалоговое окно, подтверждающее удаление выбранных элементов.

Пользователю доступно удаление элементов во всех разделах блока "Меню", разделов "Управление" (вкладки "Права доступа" и "Права на группы") и "Отчеты" (вкладка "Права на отчеты").


info_icon Примечание При попытке удалить своего пользователя или организацию в окне администрирования появляется диалоговое окно, информирующее пользователя о том, что удаление невозможно.

Экспорт данных

При переходе на определенные вкладки в нижней части окна администрирования пользователю становится доступной кнопка "Экспорт", которая необходима для экспортирования данных на компьютер в виде отдельного Excel-файла.

В том случае, если администратор воспользуется поисковой строкой и после этого нажмет на кнопку "Экспорт", скаченный Excel-файл будет содержать информацию только о найденных элементах.

Пользователю доступно экспортирование данных из всех разделов блока "Меню", кроме раздела "Справочники".



Первым элементом панели инструментов является ФИО пользователя, при нажатии на которое администратор переходит на страницу редактирования его персональных данных.


help_icon Помощь При нажатии на кнопку "Помощь" происходит переадресация пользователя с главной страницы системы на страницу с данным руководством.
map_icon Карта Кнопка "Карта" осуществляет переход на главную страницу системы.
exit_icon Выход из системы При нажатии на кнопку "Выход", которая расположена в правом верхнем углу страницы, осуществляется выход из системы.




Вкладка «Пользователи» содержит основную информацию о зарегистрированных пользователях системы. При переходе на эту вкладку становится доступной таблица со следующими графами:

  • ФИО. Имя пользователя в полной форме.
  • Логин. Имя пользователя, под которым он осуществляет вход в систему.
  • Роль. Роль пользователя в системе (администратор, заказчик и т.д.).
  • Организация. Принадлежность пользователя к организации.
  • Админ. В этой графе расположены переключатели, определяющие наличие прав администрирования у пользователя.

Управление пользователями

При переходе на вкладку "Пользователи" администратор может воспользоваться поисковой строкой, а также инструментами для создания новых пользователей и редактирования/удаления уже существующих.


Добавление нового пользователя

Для добавления нового пользователя в систему нажмите на кнопку "Создать", которая расположена на вкладке "Пользователи" пункта меню "Управление". При нажатии на эту кнопку в окне администрирования открывается форма для заполнения, в которой необходимо:

  • определить роль пользователя в системе;
  • выбрать организацию, к которой он будет относиться;
  • заполнить личные данные пользователя (его логин, ФИО, пароль, e-mail, номер телефона, адрес, факс, паспорт и ИНН).
new_user

Редактирование информации о пользователе

Для изменения информации о пользователе нажмите на кнопку "Редактировать" или дважды щелкните по строке с ФИО выбранным пользователем. После этого в окне администрирования открывается форма (аналогичная форме добавления), в которой администратор может заполнить/изменить интересующие его поля с информацией о пользователе.


Удаление пользователя

На вкладке "Пользователи" администратор может удалить одного или нескольких пользователей одновременно. При попытке удалить собственного пользователя, в окне администрирования появляется диалоговое окно, информирующее администратора о том, что такое удаление невозможно.


Поиск пользователя

При переходе на вкладку «Пользователи» администратор может воспользоваться поисковой строкой для поиска пользователей по их ФИО или логину. Чтобы найти пользователя по организации, роли или правам администрирования, необходимо воспользоваться фильтром, который расположен под поисковой строкой.

Права доступа - это права, необходимые пользователю для доступа к слоям системы. Пользователь может обладать следующими правами: просмотр, редактирование и управление.

Право на просмотр позволяет администратору увидеть слой на панели управления в основной части сайта. Право на редактирование дает возможность добавлять к слою новые объекты, а также редактировать и удалять старые. Право на управление позволяет пользователю менять структуру слоя, стили и т.п.

На вкладке "Права доступа" администратор может ознакомиться с перечнем прав, которыми обладают пользователи системы. При переходе на эту вкладку в окне администрирования становится доступной таблица со следующими графами:

  • Пользователь. Имя пользователя в полной форме.
  • Группа. Принадлежность пользователя к группе.
  • Слой. Название слоя, к которому определяется доступ.
  • Просмотр. В графе расположены переключатели, при помощи которых администратор указывает, будет ли выбранный пользователь обладать правом на просмотр.
  • Редактирование. В графе расположены переключатели, при помощи которых администратор указывает, будет ли выбранный пользователь обладать правом на редактирование.
  • Управление. В графе расположены переключатели, при помощи которых администратор указывает, будет ли выбранный пользователь обладать правом на управление.

Управление правами доступа

На вкладке "Права доступа" администратор может воспользоваться поисковой строкой, а также инструментом для экспорта данных.

При помощи поисковой строки администратор может найти пользователя по названию слоя. Чтобы найти пользователя по группе слоев, организации или по его ФИО, необходимо воспользоваться фильтром, который расположен под поисковой строкой.

Управление организациями

На вкладке "Организации" администратор может воспользоваться поисковой строкой, а также инструментами для добавления новых организаций, редактирования и удаления уже существующих.


Добавление новой организации

Для добавления новой организации в систему нажмите на кнопку "Создать", которая расположена на вкладке "Организации" пункта меню "Управление". При нажатии на эту кнопку в окне администрирования открывается новое окно, в котором необходимо заполнить следующие поля для ввода:

  • название организации
  • её e-mail
  • номер телефона
  • адрес
  • факс
  • номер ИНН и КПП
  • наименование банка
  • номер банковского счета
  • банк КПП и банк БИК

Кроме того, справа от полей для ввода расположена «Видимая область» - это те границы карты, которые будут видны пользователям организации при входе в систему. Администратор может воспользоваться шкалой масштаба для отдаления или приближения карты, а также изменить положение карты, нажав и удерживая левую кнопку мыши. Выбрав необходимый вид, администратор может нажать на кнопку «Применить» для применения новых границ карты.

create_org

Редактирование организации

На вкладке "Организации" администратору доступно редактирование информации об организациях системы. При нажатии на кнопку "Редактировать" (или при двойном щелчке по строке с выбранной организацией) открывается форма (с теми же полями, что и в форме добавления), в которой администратор может заполнить/изменить интересующие его поля с информацией об организации.


Удаление организации

При переходе на вкладку "Организации" администратор может удалить одну или несколько организаций одновременно. При попытке удалить собственную организацию, в окне администрирования появляется диалоговое окно, информирующее администратора о том, что такое удаление невозможно.


Поиск организации

При переходе на вкладку "Организации" администратор может воспользоваться поисковой строкой для поиска организаций по их названиям.

Права на группы - это права пользователей той или иной организации на добавление слоев в указанную группу. При переходе на эту вкладку в окне администрирования становится доступной таблица со следующими графами:

  • Организация. Наименование организации.
  • Группа. Наименование группы, с которой могут взаимодействовать пользователи организации.
  • Доступ. В этой графе расположены переключатели, при помощи которых определяются права организаций на добавление слоя.

Управление правами на группы

На вкладке "Права на группы" администратор может воспользоваться поисковой строкой, а также инструментом для экспорта данных.

При помощи поисковой строки администратор может найти организацию по ее названию. Чтобы найти организацию по группе слоев, необходимо воспользоваться фильтром, который расположен под поисковой строкой.



На вкладке «Слои» администратор может ознакомиться с подробной информацией о слоях системы. При переходе на эту вкладку в окне администрирования становится доступной таблица со следующими графами:

  • Тип. Тип геометрии, при помощи которого объект слоя принимает определенный внешний вид на карте.
  • Название. Наименование слоев системы.
  • Английское название. Английское наименование слоев.
  • Группа. Принадлежность слоя к определенной группе системы.

В качестве типа геометрии в системе Геопортал могут выступать:

layer Точка
line Линия
polygon Полигон
image Картинка

Управление слоями

При переходе на вкладку "Слои" администратор может воспользоваться поисковой строкой, а также инструментами для создания новых слоев и редактирования/удаления уже существующих.


Добавление нового слоя

Для добавления нового слоя в систему нажмите на кнопку "Создать", которая расположена на вкладке "Слои". При нажатии на эту кнопку в окне администрирования открывается форма, в которой необходимо заполнить следующие поля:

  • название слоя (при заполнении этого поля, автоматически заполняется поле "Английское название");
  • группа, в которой будет отображаться слой;
  • хранилище данных (то есть в какой базе данных будет храниться слой);
  • тип геометрии (точка, линия, полигон);
  • стиль (базовый, простой, расширенный).
new-layer

Добавление нового слоя: стили объектов

При создании (а также редактировании) слоя пользователь может выбрать один из следующих стилей:

  • Базовый. Стиль по умолчанию, т.е. точка, линия или полигон.
  • Расширенный. Стиль, сформированный при помощи языка geocss. При выборе данного стиля в окне администрирования, справа от полей для ввода, появляется отдельная форма с кодом.
  • Простой. Стиль, в котором администратор выбирает атрибут для подписи и задает ему цвет, фон, прозрачность и размер.

При выборе простого стиля и типа геометрии "Точка" пользователь может задать форму отображения точек каждому объекту (круг, треугольник, квадрат) или выбрать стиль с иконкой. При этом на усмотрение пользователя задается цвет и размер фона, а также выполняется обводка фигуры.

Если в качестве типа геометрии выбрать линию, то пользователь сможет самостоятельно выбрать цвет и размер фона. Чтобы задать цвет для обводки, необходимо выбрать соответствующий параметр «Обводка».

Если же в качестве типа геометрии выбрать полигон, то пользователь сможет задать не только цвета и размеры для обводки, но и прозрачность для фона.


Добавление нового слоя: атрибуты

Для добавления новых атрибутов к создаваемому слою администратору необходимо перейти на вкладку "Атрибуты", которая расположена в окне создания слоя.

При переходе на эту вкладку в окне администрирования появляется таблица и форма с двумя полями: название атрибута и его тип. Чтобы добавить новый атрибут, пользователю необходимо заполнить эти поля и нажать на кнопку "Добавить", после чего создаваемый атрибут отображается в первой строке таблицы. Здесь администратору доступны следующие действия:

  • изменение названия атрибута;
  • выбор его типа (строка, целое число, число с плавающей точкой);
  • определение дополнительных функций у атрибута (будет ли он являться заголовком и показываться в основной части сайта).

Для добавления следующего атрибута администратору необходимо повторно заполнить форму с полями и нажать на кнопку "Добавить".

layer-attribute

Добавление нового слоя: дополнительные поля

Пользователь, обладающий правами администрирования, может добавлять к создаваемому слою дополнительную информацию, которая будет отображена в информационном окне в виде списка. Для этого администратору необходимо перейти на вкладку "Дополнительно", которая расположена в окне создания слоя.

При переходе на эту вкладку администратору необходимо заполнить обязательные поля для ввода (если таковые имеются) и для сохранения введенных изменений нажать на кнопку "Сохранить и выйти".


Редактирование слоя

Для изменения информации о слое нажмите на кнопку "Редактировать" или дважды щелкните по строке с названием выбранного слоя. После этого в окне администрирования открывается форма (аналогичная форме добавления), в которой администратор может заполнить/изменить интересующие его поля с информацией о слое.


Редактирование слоя: индексация

При редактировании слоя администратору становится доступной кнопка "Индексировать". При нажатии на эту кнопку происходит полное обновление информации о выбранном слое. Администратор может воспользоваться этой кнопкой в случае добавления новой информации и ее временном отсутствии в результатах поиска.


Редактирование слоя: атрибуты

Для изменения информации об атрибутах слоя нажмите на кнопку "Редактировать" на вкладке "Атрибуты" в окне редактирования слоя. Администратору становятся доступны поля для добавления новых атрибутов и редактирования уже существующих. Здесь же администратор может воспользоваться инструментом для удаления одного или нескольких атрибутов.

layer-attribute

Редактирование слоя: дополнительные поля

Для редактирования дополнительной информации администратору необходимо перейти на вкладку "Дополнительно", которая расположена в окне редактирования слоя. При переходе на эту вкладку администратор может ввести новую информацию в интересующие его поля для ввода.

Чтобы редактирование слоя прошло успешно, заполните обязательные поля (если таковые имеются) и нажмите на кнопку "Сохранить и выйти". Для отмены редактирования слоя, нажмите на кнопку "Отмена".


Редактирование слоя: кластеризация

Если администратор выберет точечный слой для редактирования (т.е. слой с типом геометрии "Точка"), то в окне администрирования помимо вкладок "Основное" и "Атрибуты", появляется вкладка "Кластеризация".

При переходе на эту вкладку в окне редактирования открывается форма, в которой пользователь может включить кластеризацию, задать ей максимальный зум, а также создать новый кластер. Здесь же становятся доступными графы со следующими заголовками: количество объектов, изображение и цвет подписи.

Для добавления нового кластера необходимо:

  • ввести в поле для ввода определенное количество объектов, которое будет содержаться в этом кластере;
  • выбрать изображение, которое будет отображаться на карте;
  • задать цвет подписи.

Чтобы новый кластер появился в списке уже существующих кластеров, пользователю необходимо нажать на кнопку «Добавить».

clasterizacia

В графе «Количество объектов» отображается не просто ранее заданное число объектов, а их диапазон, который соответствует конкретному кластеру. Так, если напротив первого кластера стоит число 5, напротив второго – 10, а напротив третьего – 15 (как показано на рисунке), то это означает, что в первый кластер попадает до 5 объектов, во второй – от 6 до 10, а в третий – от 11 до 15. При этом если третий кластер с 15 объектами является последним в списке, то для него не будет существовать конечного числа объектов.

В графе «Изображение» хранятся изображения кластеров, которые становятся доступными при просмотре карты. А в графе «Цвет подписи» отображаются цвета, которым должна обладать подпись.


Удаление слоя

На вкладке "Слои" администратору доступны кнопки для удаления информации о слоях системы.


Поиск слоя

При переходе на вкладку «Слои» администратор может воспользоваться поисковой строкой для поиска слоя по его названию. Чтобы найти слой по группе, хранилищу данных, по типу геометрии или по растровому изображению, необходимо воспользоваться фильтром, который расположен под поисковой строкой.

При выборе фильтра "Растровый" в поисковом окне появляется форма, в которой пользователю необходимо поставить галочку напротив названия фильтра, чтобы провести сортировку. После этого в окне администрирования отображаются только те слои, у которых в качестве типа геометрии заданы изображения. Если пользователь уберет галочку повторным нажатием на форму, в окне администрирования отобразятся все слои, за исключением тех, у которых в качестве типа геометрии заданы изображения.


Загрузка слоя

Для того чтобы загрузить слой в систему, необходимо нажать на кнопку «Загрузить», которая расположена среди элементов вкладки «Слои».

При нажатии на эту кнопку в окне администрирования открывается всплывающее окно, через которое пользователь может выбрать слой со своего компьютера. К загрузке допускаются заархивированные в zip shape-слои, а также файлы формата tiff.

После того как пользователь загрузил слой, ему открывается такое же окно, что и при редактировании слоя. При этом атрибуты (если таковые имеются) задаются автоматически. Кроме того, администратор может самостоятельно выбрать хранилище данных из представленного списка во вкладке «Основное».

Кнопка "Сохранить порядок"

На вкладке «Группы» администратору доступна кнопка «Сохранить порядок». Она используется в тех случаях, когда необходимо отсортировать группы по алфавиту (или по возрастанию/убыванию слоев) и сохранить в системе получившийся порядок. При нажатии на кнопку "Сохранить порядок" происходит автоматическая смена порядковых номеров (в графе "№") для отсортированных групп.

Для того чтобы переставить группы местами, пользователю необходимо нажать на определенную группу левой кнопкой мыши и, не отпуская кнопку, переместить ее в нужную строку. После этого администратор может нажать кнопку "Сохранить порядок", чтобы сохранить получившийся порядок в системе.

Управление группами

При переходе на вкладку "Группы" администратор может воспользоваться поисковой строкой, а также инструментами для создания новых групп и редактирования/удаления уже существующих.


Добавление новой группы

Для добавления новой группы в систему, нажмите на кнопку «Создать», которая расположена среди элементов пункта меню «Слои». При нажатии на эту кнопку в окне администрирования открывается новое окно, в котором пользователю предлагается ввести название новой группы.


Редактирование группы

При редактировании группы в окне администрирования открывается новое окно со следующими вкладками: основное и слои.

На вкладке "Основное" администратору доступно редактирование наименования группы. При переходе на вкладку "Слои" администратор может просмотреть информацию о слоях, принадлежащих данной группе (порядковый номер, название заголовка и английское название).

Чтобы поменять слои местами, пользователю необходимо нажать левой кнопкой мыши на название слоя и, не отпуская кнопку, переместить слой в нужную строку.


Удаление группы

На вкладке "Группы" администратору доступны кнопки для удаления информации о группах системы.


Поиск группы

При переходе на вкладку «Группы» администратор может воспользоваться поисковой строкой для поиска групп по их названию.

Вкладка "Список отчетов"

На вкладке "Список отчетов" администратор может ознакомиться со всеми отчетами системы. Наименования отчетов хранятся в графе с заголовком "Название". Здесь же администратору доступна загрузка новых отчетов и редактирование/удаление уже существующих.


Для того чтобы загрузить отчет в систему, необходимо нажать на кнопку «Загрузить», которая расположена среди элементов пункта меню «Отчеты». При нажатии на эту кнопку, в окне администрирования открывается всплывающее окно, через которое пользователь может выбрать отчет со своего компьютера. К загрузке допускаются файлы формата jrxml.

После успешной загрузки отчета в систему, в окне администрирования открывается окно с названием отчета, его хранилищем и переменными. Для начала пользователю необходимо ввести название отчета, под которым его можно будет найти в системе. Затем пользователю предлагается выбрать хранилище из представленного списка баз данных.

download_report

В графах «Английское название» и «Тип» предоставленные данные не могут быть отредактированы пользователем. Однако в графе «Русское название» пользователь может ввести название переменных на русском языке. Именно эти названия будут отображаться при просмотре отчета.


При переходе на вкладку "Список отчетов" администратору становится доступной кнопка для редактирования отчетов. При нажатии на кнопку "Редактировать" (или при двойном щелчке по строке с выбранным отчетом) в окне администрирования открывается форма (с теми же полями, что и в форме загрузки), в которой администратор может заполнить/изменить интересующие его поля с информацией о выбранном отчете.


На вкладке "Список отчетов" администратору становится доступной кнопка удаления (в том числе кнопка для удаления сразу нескольких записей). При нажатии на одну из этих кнопок в окне администрирования открывается диалоговое окно, подтверждающее удаление выбранных отчетов.


На вкладке "Список отчетов" администратор может воспользоваться поисковой строкой для поиска отчетов по их названиям.

При переходе на вкладку "Права на отчеты" в окне администрирования появляются графы со следующими заголовками:

  • Пользователь. Имя пользователя в полной форме. ФИО в этой графе дублируются, так как каждому пользователю ставятся в соответствие все отчеты, существующие в системе.
  • Отчет. Название отчета.
  • Просмотр. В этой графе расположены переключатели, при помощи которых администартору необходимо определить, будет ли данный отчет доступен указанному пользователю для просмотра в информационном окне.

При переходе на вкладку "Права на отчеты" администратор может воспользоваться поисковой строкой для поиска отчетов по их названию, а также фильтром, при помощи которого может быть осуществлен поиск по ФИО пользователей.

При переходе на вкладку "Список хранилищ" в окне администрирования становится доступной таблица со следующими графами:

  • Название. Наименование хранилища.
  • Хост. Доменное имя, в котором хранится хранилище.
  • База данных. Наименование базы данных.
  • По умолчанию. Если напротив названия хранилища в графе "По умолчанию" стоит галочка, это означает, что при создании или загрузке слоя (отчета) система автоматически перенесет слой (отчет) в хранилище, которое стоит по умолчанию (в случае, если пользователь не выбрал конкретное хранилище из представленного списка).

На вкладке "Список хранилищ" администратору становится доступной поисковая строка, а также инструменты для добавления новых хранилищ и редактирования/удаления уже существующих.


Для добавления в систему нового хранилища необходимо нажать на кнопку «Создать», которая расположена среди элементов вкладки «Список хранилищ». При нажатии на эту кнопку в окне администрирования открывается новое окно, в котором необходимо заполнить следующие поля:

  • название хранилища
  • хост
  • порт
  • логин пользователя
  • пароль
  • имя базы данных
  • схема данных
create_datastores

При переходе на вкладку "Список хранилищ" администратору становится доступной кнопка для редактирования хранилищ. При нажатии на кнопку "Редактировать" (или при двойном щелчке по строке с выбранным хранилищем) в окне администрирования открывается форма (с теми же полями, что и в форме добавления), в которой администратор может заполнить/изменить интересующие его поля с информацией о выбранном хранилище. Администратору доступны все поля для редактирования, за исключением поля «Название».


На вкладке "Список хранилищ" администратору становится доступной кнопка удаления (в том числе кнопка для удаления сразу нескольких записей). При нажатии на одну из этих кнопок в окне администрирования открывается диалоговое окно, подтверждающее удаление выбранных хранилищ.


Для того чтобы опубликовать некоторый слой в системе, наведите курсор мыши на строку с названием хранилища и нажмите на появившуюся справа кнопку table - "Доступные таблицы". При нажатии на эту кнопку открывается новое окно, в котором администратор может ознакомиться с полным списком доступных слоев хранилища, а также их типами (точка, линия, полигон).

Кроме того, в открывшемся окне администратор может просмотреть, какие слои доступны для публикации, а какие из них уже опубликованы. Так, в графе "Опубликовано" напротив названия опубликованных слоев стоит знак check, а справа от названий неопубликованных слоев появляется кнопка "Опубликовать".

При нажатии на кнопку "Опубликовать" система переводит администратора в окно редактирования выбранного слоя. В открывшемся окне администратору необходимо выбрать группу, в которой будет опубликован слой, определить его стиль, изменить название, а также при необходимости добавить новые атрибуты (во вкладке "Атрибуты") и дополнительные поля (во вкладке "Дополнительно").

Чтобы опубликовать слой в системе, заполните необходимые поля для ввода и нажмите на кнопку "Сохранить и выйти". Чтобы отменить публикацию слоя, нажмите на кнопку "Отмена".


В пункте меню «Хранилища» администратор может воспользоваться поисковой строкой для поиска хранилища по его названию, по имени базы данных или номеру хоста. Кроме того, поиск может быть осуществлен при помощи фильтра «Из инфраструктуры», который позволяет найти хранилища, работающие с системой MapEditor.

При переходе на вкладку "Изображение" администратору становится доступной таблица со следующими графами:

  • Название. Наименование иконки.
  • Изображение. Иконка, которая может быть использована при создании стилей, а также при добавлении кластеризации к точечным слоям.

На вкладке "Изображение" администратору становится доступной поисковая строка, а также инструменты для добавления новых иконок и редактирования/удаления уже существующих.


Для того чтобы добавить новое изображение, необходимо нажать на кнопку «Создать», которая расположена среди элементов вкладки «Изображение». При нажатии на эту кнопку в окне администрирования открывается окно, в котором пользователь может ввести название иконки, а также загрузить изображение, нажав на соответствующую форму загрузки.


При переходе на вкладку "Изображение" администратору становится доступной кнопка для редактирования иконок. При нажатии на кнопку "Редактировать" (или при двойном щелчке по строке с выбранной иконкой) в окне администрирования открывается форма (с теми же полями, что и в форме добавления), в которой администратор может заполнить/изменить интересующие его поля с информацией о выбранной иконке.


На вкладке "Изображение" администратору становится доступной кнопка удаления (в том числе кнопка для удаления сразу нескольких записей). При нажатии на одну из этих кнопок в окне администрирования открывается диалоговое окно, подтверждающее удаление выбранных иконок.


В пункте меню «Изображение» администратор может воспользоваться поисковой строкой для поиска изображений по их названиям.

На вкладке "Поля" администратор может просмотреть дополнительные поля, которые отображаются на вкладке "Дополнительно" при создании или редактировании слоя, а также в информационном окне в клиентской части сайта. При переходе на вкладку "Поля" администратору становится доступной таблица со следующими графами:

  • Название. Название дополнительного поля.
  • Тип. Тип данных (строка, целое число, дробь, список, условие, дата).
  • Значение по умолчанию. Данные, которые изначально указываются в дополнительном поле.
  • Обязательное. В этой графе расположены переключатели, при помощи которых администратор определяет, будет ли выбранное поле обязательным к заполнению.
  • Отображается. В этой графе расположены переключатели, при помощи которых администратор определяет, будет ли выбранное поле отображаться на вкладке "Дополнительно" при создании или редактировании слоя, а также в информационном окне в клиентской части сайта.

На вкладке "Поля" администратору становится доступной поисковая строка, а также инструменты для добавления новых полей и редактирования/удаления уже существующих.


На вкладке "Поля" администратор может добавить новое поле для ввода дополнительной информации о создаваемом слое. Для этого ему необходимо нажать на кнопку "Создать", которая расположена среди элементов вкладки "Поля".

При нажатии на эту кнопку открывается окно создания поля, в котором пользователю необходимо:

  • ввести название поля;
  • выбрать его тип (строка, целое число, дробное число, дата, условие, список);
  • определить, будет ли поле обязательным к заполнению и будет ли оно показано в информационном окне в клиентской части сайта.

В зависимости от выбранного типа поля в форме появляются новые поля для ввода. К примеру, если администратор добавил поле с типом "Cтрока", в форме появляются следующие поля для ввода:

  • валидация поля,
  • минимальная длина строки,
  • максимальная длина строки,
  • значение по умолчанию.

Для изменения информации о дополнительном поле нажмите на кнопку "Редактировать" или дважды щелкните по строке с названием выбранного поля. После этого в окне администрирования открывается форма (аналогичная форме добавления), в которой администратор может изменить интересующую его информацию о дополнительных полях.


На вкладке "Поля" администратору доступны кнопки для удаления дополнительных полей.


На вкладке "Поля" администратор может воспользоваться поисковой строкой для поиска дополнительных полей по их названиям. Кроме того, администрутору доступен фильтр, расположенный под поисковой строкой, при помощи которого можно осуществить поиск дополнительных полей по следующим критериям: "Тип поля", "Обязательное поле" и "Отображается".


Г Группы
И Изображение
М Меню
О Организации
П Панель администрирования
С Слои
У Управление
Х Хранилища
Э Элементы управления
-->